Ðàáîòà ñ êàðòàìè

Работа с картами

Top Next

Редактор контрольных точек поддерживает два тика карт: векторные и онлайн.

У каждого типа карт есть свои отдельные особенности. Онлайн карты быстро загружаются, работая с векторными картами ВЫ можете импортировать объекты, превращая их в КТ. Карта перемещается левой кнопкой мыши. Выделение объектов векторной карты также осуществляется левой кнопкой мыши. Если рисование выбрано тоже левой клавишей, то перемещение и выделение во время рисования и редактирования осуществляется с нажатой клавишей «Shift». На рисунке ниже приведён режим работы программы с векторными картами. Красным выделена кнопка открытия карты.

На следующем рисунке приведён режим работы с онлайн картами.

Красным выделена кнопка остановки загрузки карты из интернета. Она не активна, когда не происходит загрузка новых сегментов карты.

Приближать и отдалять карту можно используя колесо мыши или клавиши «+» или «-».


Ïðåîáðàçîâàíèå îáúåêòîâ âåêòîðíîé êàðòû â ÊÒ

Преобразование объектов векторной карты в КТ

Top Previous Next

Выделяем полигон левой клавишей мыши. Если объект можно преобразовать в КТ выпадает контекстное меню. Смотрите рисунок ниже:

Выбираете левой клавишей «Преобразовать в КТ?». Появиться меню «Параметры контрольной точки», выбираете и устанавливаете нужные Вам параметры и нажимаете «ОК». При нажатии «Отмена», параметры установятся по умолчанию.

На рисунке ниже мы видим результат:


Ãðóïïîâîå ïðåîáðàçîâàíèå ïîëèãîíîâ â ôàéë ÊÒ èëè *.plt ôàéëû

При преобразовании в файл КТ, файл будет открыт редактором. Если мы хотим преобразовать в файлы *.plt, то надо будет выбрать директорию, куда это сделать. Файлы *.plt полигонов могут быть использованы для расчёта полей.

Вызываем меню: «Правка» -> «Групповое преобразование полигонов в файл КТ или *.plt файлы»

Описание.

Данная функция доступна для векторных карт, поддерживаемых векторным движком «АвтоГРАФ». Для начала выбираем направление преобразования, далее выбираем типы, нужные нам. Нажимаем «OK». Как видите всё очень просто.


Ðàáîòà ñ ÊÒ

Работа с контрольными точками

Редактор поддерживает два типа контрольных точек, окружности и многоугольники. Количество углов многоугольника может быть любым, но не меньше трёх.

Рисование и редактирование КТ можно производить либо правой, либо левой кнопкой. Настройка производится так:

Выделение КТ осуществляется только правой кнопкой. Кнопки, выделенные красным, отвечают за выбор объекта, который мы будем рисовать. Слева на право, соответственно: рисование полигона, рисование окружности, рисование трека.


Ðèñîâàíèå ÊÒ

Рисование КТ

Перед рисованием выбираем тип КТ, которую хотим нарисовать. Устанавливаем точку на экране, если это окружность, то устанавливаем центр. Установка точки осуществляется так: нажал кнопку мыши, отпустил. После того, как Вы ввели все нужные Вам точки, для окружности установили нужный радиус, нажимаем клавишу «Ввод» («Enter»). Появиться меню «Параметры контрольной точки», выбираете и устанавливаете нужные Вам параметры и нажимаете «ОК». При нажатии «Отмена», параметры установятся по умолчанию.

При рисовании трека после нажатия клавиши «Ввод» («Enter») Вы сразу увидите нарисованный Вами трек.

Рисование внутреннего полигона осуществляется аналогично внешнему, за исключением того, что предварительно надо указать, что рисуем внутренний полигон. Как это сделать, указано на рисунке ниже:

Также во время рисования Вы можете: отменить нарисованную фигуру нажав «Esc», отменить последнею введённую точку (для полигонов) нажав «Backspace», можете наблюдать изменение площади и периметра рисуемой Вами фигуры, приближать и отдалять карту, перемещать карту. Если рисование осуществляется левой клавишей, то перемещение карты в режиме редактирования производится с нажатой клавишей «Shift». Примечание: приближая и отдаляя карту, происходит пересчёт координат рисуемой КТ, поэтому вносятся погрешности. Не злоупотребляйте приближением и отдалением карты во время редактирования и рисования.


Ðåäàêòèðîâàíèå ÊÒ

Редактирование КТ

Переходим в режим редактирования.

Правой клавишей выбираем КТ. В появившемся контекстном меню выбираем левой клавишей мыши «Редактировать»:

Сам процесс редактирования очень прост. Рассмотри кратко основные возможности. Перемещение точки. Выделение происходит нажатием кнопки мыши, по принципу нажал – отпустил. После выделения Вы захватываете точку и можете её перемещать в любое нужное Вам место. Для установки на новом месте совершаем аналогичные действия её выделению. Выделенную точку можно удалить, нажав клавишу «DELETE». Добавление новой точки. Просто помещаем курсор на линию, нажимаем и отпускаем клавишу, всё, новая точка появилась.

Заканчивается процесс редактирования нажатием клавиши «Ввод» («Enter»). На рисунке ниже можем увидеть результат изменения нашей выделенной КТ.

Войдя в режим редактирования, также Вы можете: перемещать фигуру целиком, используя стрелочки на клавиатуре, удалять и приближать карту, перемещать карту. Если рисование осуществляется левой клавишей, то перемещение карты в режиме редактирования производится с нажатой клавишей «Shift». Примечание: приближая и отдаляя карту, происходит пересчёт координат редактируемой КТ, поэтому вносятся погрешности. Не злоупотребляйте приближением и отдалением карты во время редактирования и рисования. Вы можете выделить группу вершин многоугольника и, например, удалить их. Выделение группы вершин многоугольника осуществляется в режиме редактирования правой клавишей мыши:


Ðåäàêòèðîâàíèå ïàðàìåòðîâ ÊÒ

Редактирование параметров КТ

Осуществляется в два этапа. Сначала запускаем режим:

Затем приступаем к редактированию:

После ввода нужных Вам параметров нажимаем «ОК» (клавиша «Enter») или «Отмена» (клавиша «Esc»), для принятия или игнорирования изменений соответственно.


Ãðóïïîâîå âûäåëåíèå ÊÒ

Групповое выделение КТ

Редактор КТ поддерживает работу с групповым выделением КТ. Групповое выделение КТ осуществляется с помощью клавиши «Ctrl». На рисунке ниже приведены возможности группового выделения:

Выделять КТ можно как на карте, так и в древовидном списке. Вы можете удалить группу точек, изменить их параметры, при этом имя каждой точки останется своё, и вы можете переместить эту группу в другой файл.


Ñîõðàíåíèå ÊÒ

Сохранение КТ

КТ сохраняются в файл с расширением «*.chp». Сохранение производится путём нажатия соответствующих пунктов выделенных красным на рисунке ниже:

Также КТ типа многоугольник можно сохранить в файл с расширением «*.plt». Как это сделать показано на рисунке ниже:


Ðàáîòà ñ òðåêîì

Работа с треком

Top Previous

Трек можно загрузить или нарисовать и отредактировать самому. При этом загруженный трек можно тоже отредактировать, например для более точного и правильного построения коридора.

Загрузка трека из программы «АвтоГраф» проводится следующим образом:

Как открыть трек, показано на рисунке ниже:

На следующем рисунке красным выделено, как сохранить трек:

Режим отображения трека можно изменить в меню «Параметры».

Рисование и редактирование трека осуществляется аналогично рисованию и редактированию КТ. Вы также можете отменить ввод последней точки, Вы можете полностью отменить ввод нового трека, в режиме редактирования Вы можете также удалять и перемещать вершины трека, вы можете воспользоваться групповым выделением вершин трека. Какие клавиши клавиатуры при этом использовать было описано в разделе «Работа с КТ». Редактор поддерживает работу только с одним треком. При вводе нового трека, старый трек удаляется. Ниже красным выделены основные пункты меню для работы с треком.

Режим рисования трека:

Преобразование трека напрямую в КТ:

Режим редактирования трека:

Также трек можно получить, используя возможность автопрокладки, об этом будет говориться ниже.


Ïîñòðîåíèå êîðèäîðà ïî òðåêó

Переходим на вкладку «Построить полигон по треку».

Далее кратко рассмотрим основные возможности.

Как загружать трек, было рассмотрено выше. После того, как Вы получили трек, можно сразу перейти к построению нажав на кнопку «ПОСТРОИТЬ ПОЛИГОН».

Что означают настройки.

Разрешение. Чем меньше число, тем более точно строиться КТ, но при этом требуется больше памяти.

Отклонение. Максимально допустимая ширина коридора от трека до границы КТ.

Фильтры точек. Этот параметр устанавливает степень возможности аппроксимации данного отрезка криво прямой линией.

Настройки по умолчанию. Устанавливает наиболее популярные настройки алгоритма.

Строить внешний полигон. Разрешено построение внешней зоны.

Строить внутренний полигон. Разрешено построение внутренней зоны.

Замкнуть начало и конец трека. Замыкает начало и конец трека.

Для начала можно попробовать построить с настройками по умолчанию, а потом уже, как Вам требуется. Результат построения выводится на карту.


Àâòîïðîêëàäêà ìàðøðóòà

Для автопрокладки маршрута используются четыре новые кнопки:

Слева на право: проложить маршрут, установить навигационные точки, сбросить навигационные точки, сохранить карту с графом. Обратите внимание, что с открытой картой *.mp они не активны, кроме «сохранить». Это связано с тем, для работы с навигацией требуется новый формат *.agv. Старый не подходит! Теперь получим новый формат: для этого откроем карту *.mp, что мы уже сделали и нажмём: «сохранить карту с графом». Выбираем, куда сохранить. Открываем сохранённую карту:

Дальше приступаем собственно к прокладке маршрута:

1) Нажимаем «установить навигационные точки» и устанавливаем флажки, минимум два. Установка проводится аналогично рисованию вершин полигонов.
2) Нажимаем «проложить маршрут».
3) В итоге мы получаем просто трек, с которым можно проводить все аналогичные преобразования, которые были описаны выше.
4) Далее вы можете сбросить навигационные точки и повторить снова.

Результат:

Теперь перечислим оговорки:

1) Нужен новый формат *.agv.
2) Не всякая исходная карта польского формата (*.mp) подходит для навигации, бывает карты с не очень качественной навигацией, проверяйте.
3) Если маршрут не построился, или не до конца, значит в карте есть разрывы графа, и флажки привязаны к разным графам.
4) Изучайте возможности польского формата. В нём присутствует довольно большой навигационный потенциал, это и одностороннее движение и запреты определённых манёвром на перекрёстках и многое другое.


Ïðî÷èå ìåòîäû ïîëó÷åíèÿ ÊÒ

Так как программа периодически дополняется новыми возможностями, было решено сделать раздел, в который будут дополняться руководства к этим возможностям.


Ãðóïïîâîå ïðåîáðàçîâàíèå èíôîðìàöèîííûõ òî÷åê òðåêà â ÊÒ

Для начала нам надо передать трек в редактор, но это мы уже делать умеем, если читали раздел «Работа с треком». Мы увидим трек, надо включить рисование этих точек, делается это так:

Отобразили, теперь можно приступить собственно к конвертированию. Вызываем меню преобразования: «Правка» -> «Групповое преобразование информационных точек трека в КТ». Появиться следующее меню:

Описание меню.

Справа мы видим доступный для преобразования список информационных точек. Слева Мы можем задать радиус получаемых КТ, время фиксации и имя КТ. Если галочка «Использовать адрес», то имя будет формироваться из типа, длительности и индекса информационной точки, в противном случае из адреса, длительности и индекса информационной точки. Вы также можете дописать свою приписку к имени.

Адрес информационной точки записывается в адрес КТ, тип, записывается в комментарий КТ. Эти поля заполняются всегда, если есть данные.

После нажатия на кнопку «Да», произойдёт преобразование.